USA7s

 

Go Back   USA7s > Technical > General Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 06-20-2012, 07:34 PM
Canadian 7's Avatar
Canadian 7 Canadian 7 is offline
Senior Member
 
Join Date: Jul 2011
Location: Toronto, Canada
Posts: 135
Default Mbe ecu

Anybody running a MBE ignition only ECU?
Reply With Quote
  #2  
Old 06-20-2012, 08:49 PM
blubarisax's Avatar
blubarisax blubarisax is offline
Senior Member
 
Join Date: Jul 2010
Location: Mahwah, NJ
Posts: 877
Default

Check out SBD Motorsport

They helped me get my Cosworth programed over the phone!

Karl
__________________
2010 Caterham Superlight R
Cosworth 2.3L-309HP, Sadev Sequential Gearbox, Geartronics Paddle Shift
Reply With Quote
  #3  
Old 06-21-2012, 06:35 PM
Canadian 7's Avatar
Canadian 7 Canadian 7 is offline
Senior Member
 
Join Date: Jul 2011
Location: Toronto, Canada
Posts: 135
Default

I have a Westfield with a 2l Vauxhaul and a MBE ECU. Just wondering if anybody has had any issues with them. Once in a while my car wont start. It cranks but no go. I traced it to the 12 volts that goes to the centre wire on the coil pack. The voltage stops when I try to start it. If I jump 12 volts to it directly from the battery it starts and is good for days again.

Also when driving, sometimes I hear what sounds like a loud wheezing sound coming from I think the ECU that is mounted under the dash on the passenger side.

Ron.
Reply With Quote
  #4  
Old 06-22-2012, 10:04 AM
Klasik-69's Avatar
Klasik-69 Klasik-69 is offline
Paid Club Member
 
Join Date: Mar 2011
Location: Melbourne, Floirda
Posts: 535
Default

I see you are using an ignition only control ECU and you are apparently losing the 12 power source to the coil pack. I'm not sure but I believe the ignition switch circuit powers up the coil pack vs. the ECU. The ECU triggers the coil pack. Look over your wiring schematic to see if that is the case.

Years ago on another car, I had starting issues. On the "run" position, power was supplied to the ignition but on the "start" position, the power dropped off. If I quickly let go of the "start" position and drop into the "run" position, the car would start and run. Otherwise, I could crank until the battery died. Good luck.
__________________
2004 Caterham R300
2007 C6Z06 Vette
2007 Z51 Vette ragtop
1969 Corvette Big Block
1967 Pontiac GTO
1996 Mazda Spec Miata race car
1987 Porsche 930 Turbo
2004 Porsche 996TT cabriolet
all still in the garage
Reply With Quote
  #5  
Old 06-22-2012, 01:19 PM
Klasik-69's Avatar
Klasik-69 Klasik-69 is offline
Paid Club Member
 
Join Date: Mar 2011
Location: Melbourne, Floirda
Posts: 535
Default

I just got through checking the wiring schematic of Megasquirt and Pectel and it would appear I am wrong about my assumption on the 12 volt power source. On one, power goes to a relay which feeds the ECU which then distributes to needs. Sounds like it may be a bad connection......hard to find until it goes bad completely.
__________________
2004 Caterham R300
2007 C6Z06 Vette
2007 Z51 Vette ragtop
1969 Corvette Big Block
1967 Pontiac GTO
1996 Mazda Spec Miata race car
1987 Porsche 930 Turbo
2004 Porsche 996TT cabriolet
all still in the garage
Reply With Quote
  #6  
Old 06-22-2012, 07:54 PM
Canadian 7's Avatar
Canadian 7 Canadian 7 is offline
Senior Member
 
Join Date: Jul 2011
Location: Toronto, Canada
Posts: 135
Default

Thank you for the response. I know I should trace all the wires and clean all the contacts. Having too much fun driving it though!!!!

Had my girlfriend in the car today and she seems to think the sound is coming from the rear of the car and not from under the dash. Up on the lift it goes for an inspection.
Reply With Quote
  #7  
Old 06-24-2012, 11:23 PM
westy turbo westy turbo is offline
Senior Member
 
Join Date: Jun 2011
Location: Crete
Posts: 132
Default

MBE here,but no issues.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:27 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.